Discussion in 'General Discussions' started by sanzo, Sep 20, 2016.

  1. Anatotitan

    Anatotitan Active Member

    Today I tried starting a 2x map size match. When tabbing out on the loading screen, the game crashed ("Cossacks3.exe does not respond bla bla bla"). I tried again, and the same thing happened without me tabbing out on the loading screen.
  2. bazaleem

    bazaleem New Member

    I play again with different choices and now I finish this map (last one )
  3. kbidols

    kbidols New Member

    Yes, but only after I minimized to the desktop by pressing ALT+TAB.
  4. An example for unwanted impacts I found. Recently GSC changed the minimum distance for the building in the game. That was welcome by many users. Now, see the attached screenshot. Not enough peasants can walk through the narrow path between the townhall and the market. Instead of that some walk continuously arround the market. The solution could be: the minimum distance e. g. to the townhall, the storehouse and the barracks could be increased a little bit.

    Attached Files:

  5. Commodore

    Commodore Active Member

    Not enough peasants can walk through the narrow path
    Yes i noticed that, which makes it take longer to build stuff. This can be a fatal mistake in a no pt game.
  6. (OC)Fotheringill

    (OC)Fotheringill Active Member

    It is also bad if your base is attacked and town halls, market and blacksmith are bunched up. Give them a little room from each other for preservation's sake.
  7. Anderstein

    Anderstein Member

    I found a very embarassing bug.

    The attack upgrades for the 18 cen officer (all european nations!) don't do anything. The numbers on the unit informations don't change.
  8. juippiduipAlKuip

    juippiduipAlKuip New Member

    Mountains disappear when almost off-screen

  9. Aistis1990

    Aistis1990 Active Member

    Days of Brilliance. If I start Random map Starting with Army of Peasants or 18c Barrack with Denmark, I get automatically Loose window. And game end before it even started, I have 0 peasants 0 barracks.
  10. Ftoomsh

    Ftoomsh Well-Known Member

    I have seen a few bugs in latest patch (early bird + deluxe).

    I had no peace time set and yet game started with peace time lines and whole map visible. This only happened once. On next attempt it was okay.

    There is also something that could be called the "no orders" bug. Admittedly, it could be caused by a disconnect or temporary disconnect from the game. My internet is a little unstable since my provider "fixed" it. I am in Australia, the first world country where we get third world internet. :confused:

    With the "no orders" bug you suddenly find that no troops and no peasants will obey any new orders. They keep obeying orders set earlier. Troops on the march keep marching. Troops on guard keep guarding. Peasants working keep working. However, you notice the working peasants are not returning resources to mills, storehouses or town centers. And none of your resources numbers are changing so the miners are returning nothing either. This means the game is taking no new orders; not new manual orders from the player and not new automatic orders (return resources order) from the game engine.

    Anyone had this bug recently? Does it occur with disconnect, without or both. Of course, if it is a disconnect, temporary or permanent it is not a bug with the game. Though we would hope the game would be clever enough to implement a reconnect protocol. One game I have played auto pauses the game and waits 60 seconds for a disconnected player to reconnect. After that, players in the game get an option screen to kick the player or they can wait a bit longer if they want to. They all have to vote "kick" for the disconnected player to be kicked. This could be changed to majority vote for example.
  11. (OC)Fotheringill

    (OC)Fotheringill Active Member

    Recently? No. it did happen to me a few times during the first ten or so games I played after purchase. Then, it didn't.
  12. Aistis1990

    Aistis1990 Active Member

    When i save random map game with specific rules : Let's say capture only Art. Once i load it capture options is set to default. ;/
  13. Commodore

    Commodore Active Member

    "no orders bug" - this happens when someone gets disconnected from your game on multiplayer. You have to go round and reassign orders to all your peasants and troops otherwise they just stand there waiting. Usually you have to wait about a minute for the game to come back to life though before you can do that.
    Game needs to have a better system for handling disconnects.
  14. Daddio

    Daddio Moderator Staff Member

    Not really a bug, but a game-play request.

    When you wish to make a general assault, and hit control + A and you get all units. then you press shift + click on the units you t to attack to remove them from the list. If you are not very careful, (Hard to do if you are under attack) and the command to remove them does not complete. Then you end up sending all of you peasents into the attack. It happens to me nearly every game at least once.

    If the cont + A was for military units only then it would end this problem, and make controlling the game much easier? we already have a cont. + P for loose peasants. So I can think of no reason to ever select all peasants in the game, as most are assigned to a certain task and left alone.

    So I suggest control + A would be only military units?
    colonelburton likes this.
  15. Ebel

    Ebel Moderator Staff Member

    I have the same issue as you do, the interface often reacts poorly in larger battles or if any buildings/mine deposits are under the icon you try to click on. Lost quite a few battles because of these interface selection derps. And worse, your economy lies in tatters, you have to reassign the peasants. Absolute waste of time.

    I can find reason to be able to select all peasants though, but i would prefer that they are either a) no longer in the ctrl +A selection or (b) preferably adress the issue of the sometimes slow reacting interface controls.

    Btw, if they take out peasants from ctrl+A, you can still select all of them by selecting one and pressing CTRL+Z.
    Daddio likes this.
  16. Commodore

    Commodore Active Member

    Yes I agree that is very annoying and also happens to me quite often. I actually won one battle like it though by accident.
    There is also ctrl + alt + a which does what you ask - selects all but peasants. I think these two functions should be reversed as ctrl + a is a lot easier to do in a battle than ctrl + alt + a. This would be a quick and easy fix surely ?
    Daddio likes this.
  17. Daddio

    Daddio Moderator Staff Member

    I am sure Ebel could write the code? question is would it cause a desync in multiplayer games?
  18. (OC)Fotheringill

    (OC)Fotheringill Active Member


    Talk about keysmanship- I have witnessed both of us kill our own formations during attack by accident.
  19. dthstrk

    dthstrk New Member

    The formation would sometimes create a stuck unit which means that eventhough in formation 1 member will bestuck in place and will not move. I've seen that in single player after the patch. You have to kill the unit and put a new one to make it work.
  20. [KGR]-^K[o]K^-

    [KGR]-^K[o]K^- Moderator Staff Member

    Diplomatic Center
    All mercenaries unit have hotkey (D)

    Hotkey Space does not working properly
    If you select 1 town hall or 1 unit and then press (Space) it centers the camera on your town hall/ unit - OK

    If you select 2 town hall or 2 units or more buildings or units and then press (Space) it centers the camera between 2 town hall - WRONG
    The camera should jump to the first town hall and if you press Space again it should jump to the second town hall etc.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice