Discussion in 'General Discussions' started by sanzo, Sep 20, 2016.

  1. I currently have an odd problem in Single Player. When I double click to select multiple landing craft I get some weird number of landing craft if all the landing craft I own are selected. and the Frame Rate drops to almost zero until I unselect them?? I If I try to send them somewhere I get a "Floating Point" error? (for 12 landing craft selected I get 64, if I select less than the total number of landing craft I own I get the correct number) I use McGraphics and the Little Mod.
  2. Ftoomsh

    Ftoomsh Well-Known Member

    Well, I've not lost hope. Loss of control of units in OCMOD3 was an AI conflict issue. We caused it by modding; it's not in the basic game. We are on track to debugging it. Player versus player has been okay in tests so far.

    So with strange errors, you should if possible test the standard game. If the standard game does not have the error then the mod(s) likely caused it. Also, if you are running two mods at once, are they fully compatible? If there is even one file in common that both mods change then you could certainly get mod conflicts leading to game errors.
  3. Original-Cossacks-Player

    Original-Cossacks-Player Active Member

    The problem of unresponsive units is happening still, it happens to other players in the game as well, they literally can't control their units, and the lag can be so bad its a 20 second delay in moving a unit or getting it to attack, we all play with cable internet too, why does this happen?
  4. It's not particularly unique to Cossacks, it used to do the same thing on CnC generals when you had too many units in play.
  5. Original-Cossacks-Player

    Original-Cossacks-Player Active Member

    I've never experienced any of this in any strategy games I have played, including the original Cossacks with thousands of thousands of units on the map.
  6. voltob

    voltob New Member

    i dont able to delete in the game !!!
  7. Pan Sirko

    Pan Sirko New Member

    When i started to search the game, i was in roomwith my friends (we was 1 team) and we play against each other(randomly, sometimes we were in same team, and sometimes we were in different).
  8. Npeter87

    Npeter87 Moderator Staff Member



  9. not on generals you haven't, more than a certain amount of units would cause the units to stall online. They would effectively either delay or ignore orders online, you can experience that on this one too if you have too many units, they'll start to delay before obeying a command.

    You have to remember this version of Cossacks can bare no relation to the original in terms of game engine. The original had an extremely simple A.I logic that enabled you to have theoretically thousands on units in play and suffer no ill effect, part of the genius of the original was how good they could get the graphics to appear without really being 3D at all.

    Downside to this fantastically simple logic is if you look at the pathfinding for them, they were pretty shocking over large distances, with many units either getting lost or simply wandering too and fro between a hillock like a village idiot.

    The original game didn't stand up well to A.I games with naval combat, as even now the attack logic of send a bunch of units to your island and destroy your transport is a bit of a folly, from a players point of view, yet really the developers are admitting that the games would get too bogged down with scripts if they kept their transport and re used it. (I have seen other games tackle this downside, Rise of nations for e.g, where units automatically board their own transport without the need for a vessel, so long as you had a dock, effectively mean't seabound games are easier to script and meant the combat was far more lively across a range of maps and terrain). Bugs aside for a second, Surely your A.I opponent should come to the logical conclusion that so long as his own island is secure, he should seek to establish another base on your island to make attack a lot easier and keep the pressure on you, as well as capturing ore nodes for themselves.

    Another irk of mine is the lack of wall building that seems to be chronic on this game, given that it's far more important in this particular RTS series where a small horse mounted army could effectively outflank a much larger and slower opposing force and take their base from under them without so much as a whiff of combat. They need walls to protect their buildings from instant capture, yet they never seem to do it.

    Nowadays they need more sophisticated AI that work their way across the map or use multiple strategies to win a game, you multiply these pathfinding routines for every single unit across the internet game, you can see why it gets a bit dopey.
    Last edited: Mar 24, 2017
  10. Original-Cossacks-Player

    Original-Cossacks-Player Active Member

    When you build artillery depots, you have the max cannons you can build (for example 3 artillery depots lets you make 15 cannons) if you click to build 5 in each one and then before they are created you can click to build more and end up with more than the max limit.
  11. Anatotitan

    Anatotitan Active Member

    I had a bug in a match today that I have not seen before: enemy artrillery had damaged a gold mine, so naturally I send peasants to repair it. At the same time I upgraded the mine. I did not pay attention at what point this happened, but when I later checked to send more peasants into the mine, I found it to not be at maximum health. However when I sent the peasants again to repair it, they just stopped doing anything, just standing in place. So I could not send them into the mine, because the mouse would turn into the repair symbol when hovering over the mine, but the peasants would not react to my order to repair the mine, essentially making the mine worthless to me.

    When I destroyed the mine and rebuild it, it worked fine again. I guess repairing the mine at the same time as upgrading it somehow fucked it up.

    I think an error like that could be avoided if we just had an auto-fill button for idle mines.
  12. Aduhi

    Aduhi Member

    Yes, this button would help us a lot, especially when we have got no time.
  13. brocart

    brocart New Member

    It is impossible to add a building using the queue and keyboard, you are obliged to left click. Which is ok with the current game speed, but not skill oriented with faster game speed. This should be fixed.
    (I mean pressing shift + the letter corresponding to the building you wanna create).

    Besides, you should divide by 2 units time creation for all units, and decrease by 2 the formations requirements, to make micro management more useful and important. (thats just an idea like that, but this should be explored, as finally one formation of 120 soldiers is not considered as 120 units, but just 1 unit ...)
  14. antonEU

    antonEU Member

    20170410111124_1.jpg So i found a bug pls fix this. This is the second time that this happened, and the Ship can shoot at the buildings and soldiers etc.
  15. Anatotitan

    Anatotitan Active Member

    I had two bugs in a match today. At one point my troops would just stop attacking the enemy and just pile up, without being attacked themselves.

    Another bug is that you cannot scroll down in the post-match statistics to see which units everyone has built and lost. You only see the upper ~12 units or so, while usually not seeing any buildings at all.
  16. Anatotitan

    Anatotitan Active Member

    Had a bug today where my max population was 25 lower than what was displayed. For example, when my max pop was said to be 1000, I could only built 975 units.
    I was playing as Russia and had some conquered turkish and danish townhalls, but I assume the bug has to do with an enemy conquering one of my huts.
  17. Foeurdr

    Foeurdr Moderator Staff Member

    I had a problem with the raider, despite upgrading his attack on the stable it didn't give him more attack. The one from the blacksmith worked though.
  18. Kamilow

    Kamilow Well-Known Member

    Dutch Dragon 18c. does not shoot to enemy.
  19. Kamilow

    Kamilow Well-Known Member

    When Scottish Piper goes, the drum sound plays. Interesting that Scottish piper in england roster works correct.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice