Known problems and solutions!

Discussion in 'Announcements' started by Atem, Sep 24, 2016.

  1. Dalton Hallum

    Dalton Hallum New Member

    Hey thanks alot that worked. It's weird that i was able to play the game for so long and then have this randomly start happening. I'm glad that its fixed now thanks alot.
  2. Ftoomsh

    Ftoomsh Well-Known Member

    My new patched C3 version is

    First attempt at a multiplayer game in this patch led to;
    "Access Violation at address 0040584B in module cossacks.exe read of address 000000FD.

    Program frozen and I had to go to task manager to end the program.

    I attempted another game in multiplayer in shell. Same result. It happened when I sited the Mill after placing my Town Centre in my build queue.

    I then tried a 1v1 vs. the computer AI, obviously not in shell, and same result. It happens when I try to build a mill. In these tests I was Austria.

    As a further test, I tried the Austrian starting build queue the other way round. The mill queued okay and then the error happened when I queued Town Centre as second building.

    Next test, tried Turkey. Different nation, different Town Centre, different mill type. Same error again. So it is caused by the second structure of any nation (at a guess without full testing).

    I have 4 GB memory. My operating system, Win 10, and all running processes including for example, including Steam, use 1.2 GB. I have 2.7 GB left available.

    Last edited: Sep 28, 2016
    [KGR]CATWEAZEL likes this.

    [KGR]CATWEAZEL Moderator Staff Member

    I get access violation error very often as well!
  4. Tchey

    Tchey New Member

    Not only, i have freeze also in advanced game. I have to use F5 (Quick Save) a lot since about 2 patch ago...
  5. Burpleronnie

    Burpleronnie New Member

    I have the same problem as Ftoomish

    New game breaking bug introduced, Crash to desktop after queuing up multiple buildings in random map skirmish mode.( Error message: Access violation at address 0040584B in module 'cossacks.exe'. Read of address 000000FD.)

    To reproduce: start a skirmish game>select all villagers>Hold shift>Build a Mill>Build 2 Town Centres>Crash

    I have tried a number of alternate build orders and most buildings work fine, it appears that the bug has something to do with building a town centre. although it is possible to build a town centre under some circumstances.
  6. AlimkaMDK

    AlimkaMDK New Member

    I have the same problem after the last update, when I put the mill takes off error.
    "Access Violation at address 0040584B in module cossacks.exe read of address 000000FD"
  7. Ftoomsh

    Ftoomsh Well-Known Member

    As an update to my posting of the Access Violation crash as above. It actually seems to be a "time in the game" issue. I did another test where I started a game vs. computer AI and I built nothing, just waved my mouse cursor around a bit. Sure enough, within about 5 seconds the game crashed with "Access Violation at address 0040584B in module cossacks.exe read of address 000000FD."

    So my game is totally broken. I can't play Cossacks 3 Deluxe which I paid for. I hope a fix comes soon on this. It seems to be a bug which is affecting at least a significant subset of C3 game buyers. I hope the Developers make this a priority fix. Heck, I can't even play the AI in random games.

    I don't believe this is related to my graphics card as it is a basic cossacks.exe issue. Can any person with technical knowledge comment on this?

    But bottom line, this needs a fix or a workaround very soon please.
  8. Emperor Highlander

    Emperor Highlander Highlander Staff Member

    Have you tried running as administrator?
  9. Hooysse

    Hooysse Active Member

    I just had a Access Violation error while building a french forge...
  10. Atem

    Atem Administrator Staff Member

  11. Hooysse

    Hooysse Active Member

    I have an Nvidea GTX 970, it was an Access Violation error with a long code error and cossacks3.exe at the end, I already tried the fix in windows DEP thingy that you posted a while ago. It doesn't happen all the time, it must have happened 5 or 6 times since the game came out, but its still a problem....
  12. Atem

    Atem Administrator Staff Member

    OK, did you look through your processes in task manager in order to find, XSplit, Raptr or AMD Evolve?
    And please update your game version. The best way is to restart Steam shell
  13. Hooysse

    Hooysse Active Member

    I only have the Nvidea GeForce Experience app, so i dont know if it has something to do with the crashes...I will try tomorrow to run some tests by killing all nvidea processes and see if Ill get a crash.
  14. Ftoomsh

    Ftoomsh Well-Known Member

    I can report now that version is out and on my PC. I started it in administrator mode and it ran like a dream. Problem solved, thank you Atem, Developers, Programmers etc. :)
  15. Ftoomsh

    Ftoomsh Well-Known Member

    Some of my games, the other player never starts. He never gets control of his peasants. Not sure why this happens.

    Also, I have had trouble with miners disappearing out of mines. The mines are full. I do not empty them. I do not run out of food, so no starving miners. Yet a mine just empties somehow . The peasant just disappear. I had one game where it happened to 3 mines; 2 gold mines and an iron mine. First I know about it is that I run out of gold or iron when I shouldn't. I have to refill the mines with miners.

    Keep up the good work! Game is great!
  16. AlimkaMDK

    AlimkaMDK New Member

    я нашел 1 способов как можно играть. Я при постройки не зажимаю Shift и строю последовательно отдельными группами рабочих, по этой ошибки не вылетает. Но теперь бывает другая ошибка, поэтому играть не возможно. по крайней мере можно играть как я описал ранее но развитие бывает медленее
  17. Atem

    Atem Administrator Staff Member

    Also important:
    - fresh drivers
    - please try to turn on\off vsync
    - run game in windowed fullscreen
  18. Emperor Highlander

    Emperor Highlander Highlander Staff Member

    To add what Atem has said, make sure your driver is cleanly updates if not your "driver" will still have older files which can cause sync errors.
  19. Atem

    Atem Administrator Staff Member

    Recently we've faced a problem on playr's PC - his drivers were updated, but not for the correct hardware. He solved all his problems by clearing all nVidia soft, then run intel soft update (in was a laptop with two cards and), it updated intel graphics driver and after that nVidia driver took his right place.
  20. Hooysse

    Hooysse Active Member

    well without the GeForce Experience app, i played two full games not a crash so far. drivers already updated, I always have Vsync on for all games, game already on windowed fullscreen.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice