Modding and Playing Problems

Discussion in 'Modding' started by Ftoomsh, Mar 7, 2017.

  1. Ftoomsh

    Ftoomsh Well-Known Member

    I am having the following problems. I wonder if anyone has any suggestions.

    1. When I play, miners disappear out of some of my mines, usually after the first battles. I do not run out of food but some mines that had 5 or 10 peasants in them will then only have say 2 or 6. The peasants really are gone and I have't unloaded them. I have to put new peasants in the mine.

    2. I now get more game freezes than any player I know.

    3. When I test my mod in the editor, I lose control of units after a short time, about when I build an academy (with 5,000s resources start) after my market and 2 x barracks. When I lose control of units, peasants stop gathering too and units stop coming out of buildings. When another modder (General WVPM) tested this same mod he had no problems. He could not replicate my bug.


    What should I check? I guess I should check;

    (a) file validation?
    (b) do a full reinstall of game?
    (c) is my Windows system corrupt?
    (d) do I have too little memory? (I have 4 gig and 2 gig is used up by running processes before I start a game or test.
    (e) My NVIDIA Geforce. Is this a problem? Do other people run NVIDIA okay? What are the best settings?


    Hoping someone has some suggestions, please.
     
  2. A. Soldier

    A. Soldier Active Member

    I would play at the lowest possible settings if I was you.
     
  3. Francesco_Cavalli

    Francesco_Cavalli Active Member

    Your unit freezing might be a clash between two mods OR a problem with a change you might have made - I have one trying to combine my mod with General's - combining leads to a freeze on map generation, and running both simultaneously leads to a crash as soon as a player builds a military unit (when our mods part ways stats-wise)
     
  4. General WVPM

    General WVPM Member

    I tried you mod again in the editor, this time vs AI (instead of editor) and it did what you described.
    I'm not sure why it did that. The only red text (with blue background) I got was from the MouseDown state machine, saying that the mine I build was neither gold, iron nor coal (it was gold).
    However, the game continued for 2 minutes before the freeze occured.
    As for Cavalli, use the conversation if you want to discuss merging and issues with that. I'd be happy to help.
     
  5. General WVPM

    General WVPM Member

    The problem was caused by pseudoformations the AI is using and the FFF. It's fixed in the updated version.
     
  6. Ftoomsh

    Ftoomsh Well-Known Member

    I am sorry to report that it is not fully fixed in OCMOD3 (in testing) which uses your FFF. I am not sure if I caused a regression by my modding or if there is still a problem with pseudo-formations in the FFF version which is merged with OCMOD3. The bug now occurs later on in the game or even sometimes not at all. It's an intermittent fault in other words. It seems to me that the AI is still making pseudo-formations of 17th muskets, mercenary archers and cavalry. Even these don't always cause the bug. But something about it is causing the bug intermittently.

    The funniest event was when the bug happened in one test game and the AI side "Impossible" soon started to starve. Then when a few AI units died (including obviously a key unit or units making a pseudo-formation) the game gave control of units back to the AI and back to me. The AI set all its peasants back to work. I was able to control my peasants again (set them to work) and control my military units again. So, we are really close to fully correcting this bug in OCMOD3. I just need your help again... as usual. :)

    Player vs player control seems to be fine but we need some bigger tests of it this week-end.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice